Jump to content


Jcreator Wont Work But Other Ides Do?


  • Please log in to reply
4 replies to this topic

#1 wtfJCreator

wtfJCreator

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 01 February 2012 - 09:39 PM

I am trying to get jcreator to work on my new computer, but for some reason its not. I have the jdk installed and set the path to it in Configure > Options > JDK profiles. I have tried both Netbeans and Eclipse and they work fine. I've used JCreator for a long time and am most familiar with it so i would like to get it working. When i try to run a file, it says:

Failed to start the following executable, "C:\Program Files\Java\jre7\bin\javac.exe" -g -classpath I:\java\labs\bullseye -d I:\java\labs\bullseye I:\java\labs\bullseye\Bullseye.java

Any ideas on how to fix this?

#2 xinox

xinox

    Administrator

  • Admin
  • 525 posts

Posted 02 February 2012 - 01:00 AM

"C:\Program Files\Java\jre7\bin\javac.exe" doesn't exist, because the profile is pointing to the jre directory instead of the jdk.

The solution is create a new JDK Profile via options.

#3 wtfJCreator

wtfJCreator

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 05 February 2012 - 07:01 PM

View Postxinox, on 02 February 2012 - 01:00 AM, said:

"C:\Program Files\Java\jre7\bin\javac.exe" doesn't exist, because the profile is pointing to the jre directory instead of the jdk.

The solution is create a new JDK Profile via options.

All of the JDK profiles are pointing to the correct place, how do i make it so it looks for "javac.exe" in the correct place? I would appreciate it if you were a little less vague.

#4 nyccanuck

nyccanuck

    Advanced Member

  • Members
  • PipPipPip
  • 78 posts

Posted 05 February 2012 - 09:51 PM

View PostwtfJCreator, on 05 February 2012 - 07:01 PM, said:

All of the JDK profiles are pointing to the correct place, how do i make it so it looks for "javac.exe" in the correct place? I would appreciate it if you were a little less vague.


I had the same problem and corrected it by going to the Configure: Options, then down to JDK Profiles.  I moved my JDK Version 1.7 (active version) to the top and clicked okay.
This corrected the problem on my machine.
Good luck!

#5 xinox

xinox

    Administrator

  • Admin
  • 525 posts

Posted 06 February 2012 - 08:51 PM

Which version of JCreator do you have installed?