Jump to content


Can't Run Program


  • Please log in to reply
2 replies to this topic

#1 violation

violation

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 21 February 2012 - 09:40 PM

Hello all, I am having a problem with running a small program with JCreator Pro 5.0 purchased license. I had it first installed on my desktop computer, then recently uninstalled and deleted all the files on the desktop to be able to install JCreator on my laptop. Everything installed correctly; installed the license, the jdk profile points to the jdk1.7.0_03 directory in Program Files, etc. When I build the program the build output says the process is completed, and it will create the .class file (which is located with the .java files), yet when I run the file (or f5) I get the following:


--------------------Configuration: <Default>--------------------
Usage: java [-options] class [args...]
           (to execute a class)
   or  java [-options] -jar jarfile [args...]
           (to execute a jar file)
where options include:
    -d32   use a 32-bit data model if available
    -d64   use a 64-bit data model if available
    -server   to select the "server" VM
    -hotspot   is a synonym for the "server" VM  [deprecated]
                  The default VM is server.

    -cp <class search path of directories and zip/jar files>
    -classpath <class search path of directories and zip/jar files>
                  A ; separated list of directories, JAR archives,
                  and ZIP archives to search for class files.
    -D<name>=<value>
                  set a system property
    -verbose[:class|gc|jni]
                  enable verbose output
    -version      print product version and exit
    -version:<value>
                  require the specified version to run
    -showversion  print product version and continue
    -jre-restrict-search | -no-jre-restrict-search
                  include/exclude user private JREs in the version search
    -? -help      print this help message
    -X            print help on non-standard options
    -ea[:<packagename>...|:<classname>]
    -enableassertions[:<packagename>...|:<classname>]
                  enable assertions with specified granularity
    -da[:<packagename>...|:<classname>]
    -disableassertions[:<packagename>...|:<classname>]
                  disable assertions with specified granularity
    -esa | -enablesystemassertions
                  enable system assertions
    -dsa | -disablesystemassertions
                  disable system assertions
    -agentlib:<libname>[=<options>]
                  load native agent library <libname>, e.g. -agentlib:hprof
                  see also, -agentlib:jdwp=help and -agentlib:hprof=help
    -agentpath:<pathname>[=<options>]
                  load native agent library by full pathname
    -javaagent:<jarpath>[=<options>]
                  load Java programming language agent, see java.lang.instrument
    -splash:<imagepath>
                  show splash screen with specified image
See http://www.oracle.co...tion/index.html for more details.

Process completed.

---------------------------------------------------

It was working flawlessly on my desktop (didn't change any of the settings on my laptop), so I reinstalled it on my desktop to make sure the settings were the same as what was on my laptop, and they are :/
I can't seem to figure out whats wrong, so any help is appreciated :)

#2 nyccanuck

nyccanuck

    Advanced Member

  • Members
  • PipPipPip
  • 78 posts

Posted 22 February 2012 - 04:35 AM

View Postviolation, on 21 February 2012 - 09:40 PM, said:

Hello all, I am having a problem with running a small program with JCreator Pro 5.0 purchased license. I had it first installed on my desktop computer, then recently uninstalled and deleted all the files on the desktop to be able to install JCreator on my laptop. Everything installed correctly; installed the license, the jdk profile points to the jdk1.7.0_03 directory in Program Files, etc. When I build the program the build output says the process is completed, and it will create the .class file (which is located with the .java files), yet when I run the file (or f5) I get the following:


--------------------Configuration: <Default>--------------------
Usage: java [-options] class [args...]
           (to execute a class)
   or  java [-options] -jar jarfile [args...]
           (to execute a jar file)
where options include:
    -d32   use a 32-bit data model if available
    -d64   use a 64-bit data model if available
    -server   to select the "server" VM
    -hotspot   is a synonym for the "server" VM  [deprecated]
                  The default VM is server.

    -cp <class search path of directories and zip/jar files>
    -classpath <class search path of directories and zip/jar files>
                  A ; separated list of directories, JAR archives,
                  and ZIP archives to search for class files.
    -D<name>=<value>
                  set a system property
    -verbose[:class|gc|jni]
                  enable verbose output
    -version      print product version and exit
    -version:<value>
                  require the specified version to run
    -showversion  print product version and continue
    -jre-restrict-search | -no-jre-restrict-search
                  include/exclude user private JREs in the version search
    -? -help      print this help message
    -X            print help on non-standard options
    -ea[:<packagename>...|:<classname>]
    -enableassertions[:<packagename>...|:<classname>]
                  enable assertions with specified granularity
    -da[:<packagename>...|:<classname>]
    -disableassertions[:<packagename>...|:<classname>]
                  disable assertions with specified granularity
    -esa | -enablesystemassertions
                  enable system assertions
    -dsa | -disablesystemassertions
                  disable system assertions
    -agentlib:<libname>[=<options>]
                  load native agent library <libname>, e.g. -agentlib:hprof
                  see also, -agentlib:jdwp=help and -agentlib:hprof=help
    -agentpath:<pathname>[=<options>]
                  load native agent library by full pathname
    -javaagent:<jarpath>[=<options>]
                  load Java programming language agent, see java.lang.instrument
    -splash:<imagepath>
                  show splash screen with specified image
See http://www.oracle.co...tion/index.html for more details.

Process completed.

---------------------------------------------------

It was working flawlessly on my desktop (didn't change any of the settings on my laptop), so I reinstalled it on my desktop to make sure the settings were the same as what was on my laptop, and they are :/
I can't seem to figure out whats wrong, so any help is appreciated :)

Take a look at the thread http://www.jcreator....?showtopic=7905
I had the same problem and it is now corrected.
If that does not help you, I am sure that the Admin will be able to assist you further.

#3 violation

violation

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 22 February 2012 - 05:39 AM

Hey thanks for the response :) I saw your thread before posting yet hadn't tried applying your fix =/ Ill check it out and post back :)


Update:

It seems that it has started working again, although I tried 2 things around the same time so it's difficult to point to which one works, but the solutions are as follows:

1: For win7 64 I ran the JCreator Pro shortcut as Administrator, and it told me that my trial was up and to put in license number, and did so. Started, closed and then restarted Jcreator again, as Administrator(sry for redundancy lol), and JCreator wouldn't even let me move a text file into its grey area.

2: Made sure JCreator was closed. I renamed the Options folder from the link at the lower left within the Configure-Options menu, and moved it to the desktop; started JCreator and no fix. Took a look at the hidden folder C:/ProgramData/JCreator which is the same Options folder as the link, yet this time was different. Renamed the Options folder in ProgramData/Jcreator, moved it to the desktop, started JCreator and it now works.

If it ends up not working tomorrow I dunno what to do lol.

Update 2:

Ok scratch some of that, the admin thing probably doesn't help, and didn't need to wait till tomorrow. Same thing happens to me as it does nyccanuck, I can run a program but I then have to restart JCreator, and also leave the start page up.


Update 3:

Been playing around with using the Run File command on a program while the start page is up or down, and found (I hope) a better workaround to restarting JCreator each time =/. I did each one of these a few times to make sure it was somewhat consistent:

1. Either leave the start page open, taking up the first program tab slot and then moving your programs into JCreator, or
2. Closing the start page (or leave the start page up still) and opening a dummy program in the first program tab, and opening your other programs in tab 2 or 3 and on.

For me it seems that it doesn't like to run any program, even the dummy, in the first tab. Ill keep this post updated.


Update 4:

Left JCreator alone yesterday after Update 3, so thought I should see if the workaround still worked. The workaround for me anyway still seems to be leaving the start page open and opening a program in the tab next to it. Hopefully it will work for someone else :)

Edited by violation, 23 February 2012 - 05:43 PM.